EC-CUBE4 プラグイン有効化できない現象の対処法

EC-CUBE4系からはプラグインのインストール方法が変わり、管理画面から行う仕様となりました。

従来のアップロード式から簡単になったかと思ったら
インストールできない」
有効化できない」
エラーが発生する」
と悩む人が続出しています。

今回はよくある見落とされがちな原因を公開します。

まず最初に確認すること

ec-cube動作確認済みのバージョン

PHPのバージョンは7.1~となっています。

5.Xなどの古いバージョンは使用できません。

よく見ると右側に動作確認済みに7.1.20とあります。

インストールボタン・有効化ボタンが表示されない症状の場合、バージョンを7.1.28などへ落とすことで解決するパターンが多いです。

エックスサーバーなどレンタルサーバーのデフォルト設定が最新7.3バージョンになっていることが多いので注意。

「最新バージョンだから大丈夫」ということではないみたいです。

PHPのバージョンはレンタルサーバーの管理画面から変更することができます。

もしこの症状でつまずいている人がいたら、確認してみてください。

タイトルとURLをコピーしました